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Getting started with PRIMER v7
PRIMER 7
trial software

A trial version of PRIMER 7 is freely available, which is downloadable from the PRIMER-e web
site (www.primer-e.com), and can be run without an installation key. Whilst it is a full working
implementation of all analysis routines and graphics, and permits a user’s own data to be input from
Excel or text files and analysed, it is only intended to be trial software so there are a few key
limitations – all printing, copying to the clipboard and saving of data and workspaces is disabled. In
addition, plots are watermarked so presentation-standard output is unobtainable from screen grabs.
The trial version has a 30-day expiry date, with an additional grace period, but will then cease to
operate – restarting the trial period on the same machine is then not possible.

A valid installation key can be purchased at any time from PRIMER-e, and inputting that to Help>
Install Licence when on-line will remove all such printing and saving restrictions and watermarks.
Download of the pdf versions of the comprehensive manuals can then take place, along with any
updates and a fuller set of example data directories than are available with the trial version. There
are two PRIMER 7 manuals and one PERMANOVA+ manual (if this add-on is also purchased):
User/Tutorial Manual: Clarke KR, Gorley RN (2015) PRIMER v7: User Manual/ Tutorial,
PRIMER-E, Plymouth, 296pp;
Methods Manual: Clarke KR, Gorley RN, Somerfield PJ, Warwick RM (2014) Change in marine
communities: an approach to statistical analysis and interpretation, 3rd edition, PRIMER-E,
Plymouth, 260pp;
PERMANOVA+ Manual: Anderson MJ, Gorley RN, Clarke KR (2008) PERMANOVA+ for
PRIMER: Guide to software and statistical methods, PRIMER-E, Plymouth, 214pp.
The trial software includes both PRIMER and PERMANOVA+ routines but, if only a key for
PRIMER is purchased, PERMANOVA+ routines are not enabled and their menu will no longer
appear. If a valid single-user PERMANOVA+ licence code, for operation with PRIMER v6, is
registered to you in the PRIMER-e database then you will not need to purchase PERMANOVA+
again – it is essentially the same product in operation with PRIMER 7 as it was with PRIMER 6, and
you will be given a single installation key which enables both products. All purchase enquiries about
converting this trial version into fully implemented software should be addressed to the PRIMER-e
office, primer@primer-e.com.
Opening the
trial data

After launching the PRIMER desktop by clicking on its
icon, the first step is to open a worksheet
of multivariate data, e.g. species abundances over a number of samples. The user’s own data will
typically be read into the program from Excel (*.xls or *.xlsx), though various text format input
options are also provided (or you can type entries into a newly created PRIMER worksheet and edit
it directly – though this is not commonly done). However, the PRIMER 7 trial comes with data from
a study of benthic infaunal communities in soft sediments, from 27 sites over five creeks of the Fal
estuary, SW England (with sediments contaminated to varying degrees by heavy metals, from
historic mining). Both faunal counts and environmental variables are measured at the same set of
sites, and these data will be used as the ‘Getting started’ example. You can access them, in the
‘Examples trial’ directory, with Help>Get Examples Trial, which prompts you for a folder name in
which to store these data files. Three of the four files, e.g. the data Fal nematode abundance.pri and
the hierarchy of its species, Fal nematode taxonomy.agg, have been saved in PRIMER 7’s own
internal binary format, *.pri or *.agg, unreadable by other software or earlier PRIMER versions. To
open the species × samples matrix, take File>Open from the main menu, navigate to the ‘Examples
trial’ directory in the location you have specified, and select Fal nematode abundance.pri, clicking
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Open to display the species matrix. Or, because this is a PRIMER file type, you can instead use
Windows Explorer to navigate to your specified folder and click on the Fal abundance file name.
This will launch a (further) PRIMER session, with the data matrix open in the PRIMER desktop.

Taking Edit>Properties you will see that PRIMER-format *.pri sheets carry other information on
Title, Data type, Array size, whether Samples are found in •Columns or •Rows, a Description, and
(later) the history of what pre-treatments (such as transformation) have been applied to them. With
Edit>Factors, you can see that a subsidiary sheet of three factors is also linked to this worksheet:
Creek, a single-letter abbreviation for the creeks, the full Creek name and a numeric Position factor
of the sampling sites’ location down the creek – other factors could be typed in with Add.

Reading data
in from Excel

As an example of reading in data from Excel, first open in Excel and look closely at the file Fal
environment.xls, to note the simple format of a title in box A1, column headings (unique) for the
samples in row 2, row headings (also unique) for the variables in column A, with only numeric entries
in the array itself (rows 3 to 14). This is followed by a blank row, followed by the same three factors
as above. This format must be adhered to precisely, with no extra blank rows or columns, or extra
headers, otherwise PRIMER will not be able to open it successfully.
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After File>Open, you need to find the drop-down list (bottom right of the Open dialog, as seen on
the previous page) and select Excel Files, which should now display the Fal environment.xls sheet.
Select it, and Open now takes you through a File Wizard, for which you take the defaults except to
specify (Data type•Environmental) – look at those defaults though. If this worksheet were now to be
saved in the default format (File>Save Data As), the result would be the Fal environment.pri file
already in the workspace.

Basic MVA
wizard

To cater for users completely unfamiliar with the basic outputs from a multivariate analysis, e.g. of
the species abundance matrix opened above, PRIMER 7 now has a Wizards>Basic multivariate
analysis menu item, which automatically generates robust outputs from some core routines, using
knowledge of the Data type and with the opportunity for the user to alter some inputs from their
defaults. Run this routine with the Fal nematode abundance sheet as the active matrix (click on it to
make it active – its header bar will then be a slightly darker colour than other open worksheets). Take
all the defaults on the Basic analysis wizard dialog box, i.e. just click on Finish – having first looked
closely at the choices it has made for you! – and several results and graphic windows will appear in
the display area of the PRIMER desktop (to the right). The Explorer tree area, to the left, shows the
sequence of Data worksheets and Graph outputs created by the Wizard, interspersed with Results
windows (the notebook icon) with names which describe the routine that has been run, and the tree
shows the relationships among these analyses (what they start from and what they produce) A
Wizard is just a bundled version of single routines which appear on PRIMER’s other menus or submenus, so click on each row of the Explorer tree to display the sequence of steps involved and outputs
produced. The final graphical step is a Multiplot output of four graphs, ‘rolled up’ in the tree, shown
by the + sign. Clicking on the + (or on any of the plots in the multiplot) unrolls these individual graph
names.
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It is now instructive to run through the individual analyses that the above Wizard corresponds to.
Pre-treatment
of data

Pre-treatment of the data (sometimes in more than one way) is usually desirable. For assemblage
data, transformations will reduce the dominant contribution of abundant species to Bray-Curtis
similarities. Though not usually needed for controlled (‘quantitative’) sampling, standardising of
samples to relative composition (so sample totals are all 100%) can be achieved, with Fal nematode
abundance active, using Pre-treatment>Standardise>(Standardise•Samples) & (By•Total) – the
Wizard default was not to standardise but it did give that option, where % composition is desired.
Transformation of all values (which should be after standardisation, if the latter is appropriate) is
obtained by, for example, Pre-treatment>Transform (overall)>(Transformation: Square root). A
more severe transform would have been by Fourth root or Log(X+1) or by the ultimate in severity of
transformation – reduction of the quantitative data to purely Presence/absence of each species.
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Since the purpose of transforming is to avoid the ensuing analysis becoming dominated by just one
or two species with very large abundances, and bring more species into the definition of similarity
of two assemblages – whilst at the same time avoiding giving sporadic, singleton species too much
weight – the effects of competing choices can be assessed by running the second Wizards item.
Matrix display
wizard

On active sheet Fal nematode abundance, run Wizards>Matrix display, not taking all the defaults
in this case but unticking/unchecking the (Reduce species set) box so that all species are retained,
and taking (Transformation: Square root) & (Retain sample groups>By Factor: Creek). A quite
complex set of steps are then carried out, culminating in a run of Shade Plot from the Plots menu
but all that needs to be understood for the current purpose is that the resulting shade plot is simply
an image of the data matrix, in which the abundance for each species is represented by a grey scale,
from white (absent) to black (the largest count in the worksheet). Replicates from the 5 creeks are
kept together along the x axis and the species on the y axis have been clustered and ordered in such
a way that species with similar distribution across these samples are placed together. (Multivariate
analysis does not use the order of species in the matrix but it helps the human eye to visualise data
structures by performing such re-arrangements).

Apart from it being clear that some creeks contain a rather different set of species – or at least
different abundances of the same species – an observation which is tested by the ANOSIM routine,
as part of the Basic multivariate analysis wizard (or by running ANOSIM on the resemblance
matrix directly – see later), the other message is that a single species, or a small group of species,
does not totally dominate an assessment of similarity of samples (columns) to each other. Equally
clearly, quite a number of the less frequently occurring species have (transformed) values which are
still sufficiently small in relation to the main players that they will have almost a negligible
contribution to the resulting similarity calculation. This is probably desirable, and suggests we may
have a reasonable transformation here. Contrast this with Wizards>Matrix display run again on the
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Fal nematode abundance sheet, but this time with (Transformation: None) – you can ignore the
warning that PRIMER gives you (it is trying to tell you this is a bad idea!) – and it is clear from the
resulting shade plot that only a few species will now contribute to the similarity computations. So an
assessment of biotic differences among creeks, and how this relates to differences in heavy metal
concentrations will really only be about a few numerically dominant species and not broadly
community-based. At the other extreme, if you try the severest presence/absence transform, the rare
species are now having far too much of an effect and will dilute genuine patterns from species
sampled in reasonable numbers.

There is an alternative approach to balancing contributions from different species, that of Pretreatment>Dispersion Weighting, which downweights species with highly variable counts in
replicates, which the sampling device captures in clumps rather than single individuals – relatively
more weight is therefore given to species with consistent numbers over replicates of the same
condition and these will be more reliable for assessment. If you try that pre-treatment and put the
resulting rebalanced matrix into the Matrix display wizard, the shade plot gives a matrix image not
unlike that for the square root transform, making this a possible alternative pre-treatment here.
Environmental
data

For environmental-type data, such as the Fal environment sheet, it is often appropriate to transform
individual variables differently, since they may be of disparate types. Here, the main objective is to
avoid strong skewness in the distribution over samples, since large outliers will dominate both
computation of (normalised) Euclidean distances and the Principal Component Analysis (Analyse>
PCA), which is often the multivariate ordination chosen for abiotic data. The degree of skewness, or
presence of outliers, can be visually assessed with Plots>Histogram Plot on Fal environment.
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An alternative plot which is equally useful in assessing outliers is obtained by Plots>Draftsman Plot
on active sheet Fal environment. You may wish to increase symbol size on the draftsman plot – do
this by Graph>Sample Labels & Symbols and Size: 150, for example. On the same dialog screen,
by taking the Symbols>(Plot>By factor: Creek) option, you can identify points from the differing
creeks on these scatter plots. You might also need to zoom into this plot to see more detail, with
Graph>Zoom In or the
icon on the Task Bar – repeatedly click on the plot to step the zoom in
and then use the scroll bars. There is a stepped Zoom Out or a Cancel Zoom option. An option with
the initial draftsman plot dialog is to output a correlation matrix among variables.

If there is strong right-skewness, those variables might need (say) a log transform by highlighting
them and taking Pre-treatment>Transform (individual)>(Expression: log(V+1)). Alternatively
take the rank transform, Tools>Rank Variables, which certainly gets rid of outliers!
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Although there is skewness here, there are no strong outliers and, for this demo, you can omit any
transformation. So, run Wizards>Basic multivariate analysis on Fal environment and take all the
defaults, examining the different choices made for this environmental-type matrix (e.g. normalising
variables onto a common dimensionless scale; Euclidean distance resemblance; PCA ordination).

Resemblance
calculation

Resemblance is the general term in PRIMER used to cover (dis)similarity or distance coefficients.
The next stage in both the Fal nematode and environment runs of the Basic multivariate analysis
wizard was to create an appropriate triangular resemblance matrix between all pairs of samples. This
is a run of Analyse>Resemblance on the pre-treated (transformed or normalised) worksheet.
Relevant defaults will be suggested, given the Data type, i.e. (Measure•Bray-Curtis) for biota and
(Measure•Euclidean distance) for environmental variables, and (Analyse between•Samples) in both
cases. There are, however, nearly 50 possible choices on this dialog.
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ANOSIM
tests

The wizard then runs, for both biotic and abiotic data, Analyse>ANOSIM>(Model: One-way - A)
& (Factors A: Creek)>(Type Unordered) on the respective resemblance matrices as active sheets.
This tests for statistically significant differences overall among the 5 creeks in terms of their biota
(or environmental data).
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The Results window shows the ANOSIM R statistic is large (0.82 for biota, 0.71 for environmental
variables), close to its maximum value of 1, implying very good clear separation of the creeks, and
highly significantly different from the null hypothesis value of R = 0, i.e. no creek differences. The
associated plot is a histogram of the null hypothesis values of R under random permutations and
shows that values not much more than R = 0.2 would be expected here if creeks did not differ.
ANOSIM follows this up with pairwise tests between pairs of creeks, using the 5 (or in one case 7)
locations in each creek as the replicate level, again showing significant and strong differences
between all pairs of creeks (R close to 1 in most cases, with the smallest difference between J & E).

ANOSIM tests can be much more extensive. PRIMER 7 introduces the idea of ordered ANOSIM
tests, in which a numerical factor can be defined for the groups a priori (perhaps testing for simple
time trend, or spatial gradient of change). Two-way crossed or nested, and three-way crossed, nested,
or mixed crossed and nested, designs can be defined, with any factor ordered or unordered and
analyses are then often possible without replicates as well as with them. The Fal data provides an
example of this – the 5 (or 7) sites within each creek are in ordered locations down the creeks, given
by the factor Position (B, with numeric levels 1-5 or 1-7). This factor is nested within the Creek
factor (A) in a 2-way design, denoted B(A). (Nesting means that position 3 in creek R is not assumed
to equate to position 3 in another creek – this is clear from the fact that most creeks only have 5
positions whereas R has 7). There is no replication at each position but an ANOSIM test for
significance of the Creek factor (a gradient of change in biotic assemblages down the creeks) is still
possible by running Analyse>ANOSIM>(Model: Two-way nested (B within A) - B(A)) & Factors
(A: Creek)>(Type Unordered) & (B: Position)>(Type Ordered) on the resemblance matrix (either
biotic or abiotic). For the biota, the Creek test results are unchanged from the 1-way design above,
but the Position effect is seen to be significant, with ordered (average) RO = 0.64, indicating a strong
overall gradient in communities with Position. (In the histogram below, the bin width has been
changed with Graph>Special).
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The Position effects for individual creeks can be tested one at a time, by Select>Samples>Factor
levels>(Factor name: Creek)>Levels, on the resemblance matrix, leaving only one creek letter in the
Include box – i.e. moving the rest to the Available box – then re-running one-way ANOSIM with
Factor (A: Position)>(Type Ordered). However, 5 ordered sites is minimal for such a test, though the
7 sites at R give a test with better power (and a strong biotic effect, RO = 0.76, p<0.1%).
CLUSTER
analyses

The Basic MVA wizards then run a cluster analysis, again on the respective resemblance matrices.
This routine the wizard uses is Analyse>Cluster>CLUSTER>(Cluster mode•Group average),
without taking the (SIMPROF test) option since ANOSIM rather than SIMPROF is the relevant
test when an a priori group structure is defined. However, we could choose to ignore the structure of
sites within 5 creeks and simply treat the samples as just 27 Fal estuary locations, with differing
concentrations of heavy metals in their sediments. This is not illegitimate and here will allow a
demonstration of the analysis sequence for a priori unstructured samples. The primary thrust of the
analysis is no longer ANOSIM tests and nMDS (below) display of those creek groups – instead, it is
more exploratory. One question is whether the sites fall into clusters of similar communities (or
environmental variables) at all – and, if so, which sites make up those groups. (A later question is
whether we can demonstrate observational links between biotic and abiotic data, examined with the
BEST and LINKTREE routines). In the simpler clustering question, the SIMPROF test is then
important in deciding which clusters in (for example) a hierarchical group-average cluster analysis
(UPGMA) we are entitled to interpret as distinguishable groups, statistically speaking. If we do not
tick the (ANOSIM 1-way) box in the Basic multivariate analysis wizard, it would instead run a
series of SIMPROF tests on the nodes of the cluster analysis dendrogram to determine this. Or, if
running the CLUSTER routine directly on the resemblance matrix, tick the (SIMPROF test) box
and take the defaults on the next screen, supplying the name Sprof gp for a factor which specifies
which clusters of samples are demonstrated as statistically different. In the resulting dendrogram, red
lines indicate sub-structure which has no statistical support (and therefore would be unwise to
interpret) and black lines the divisions which do have statistical support. In this Fal example, it is
interesting to note that the dendrogram does largely divide the 27 samples into the 5 creeks – which
is consistent with the clear distinction among creeks seen in 1-way ANOSIM – with some of the
creeks being further sub-divided by SIMPROF (not inconsistent with the gradient structure within
creeks found by 2-way ordered ANOSIM). You might like to accentuate the relation between the
SIMPROF groups and the creek structure by taking Graph>Sample Labels & Symbols>(Symbols
Plot)> (By factor Creek) on the dendrogram – look also at the Graph>Special options.
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Constrained
clustering

PRIMER has other clustering tools you can try: a hierarchical binary divisive cluster analysis in
unconstrained (Analyse>Cluster>UNCTREE) or constrained form (>LINKTREE) – in the latter
only divisions which have an ‘explanation’ in terms of a threshold on (typically) an environmental
variable are permitted. Both these methods share a common structure, consistent with the nonparametric treatment of resemblance matrices (which applies to tests such as ANOSIM, RELATE,
BEST and ordinations such as non-metric MDS etc), namely each group is successively sub-divided
so as to maximise the ANOSIM R statistic (PRIMER’s key measure of group separation in
multivariate space) between the two groups formed. A further non-hierarchical clustering method is
available in the Analyse>Cluster>kRCLUSTER routine, a generalisation of classical k-means
clustering to any resemblance matrix but again using only ranks. SIMPROF tests can be applied to
all methods. An example of linking a biotic cluster analysis to explanatory variables can be seen here
by first selecting just the two variables %silt/clay and Cu from Fal environment (do this by
highlighting the two rows by clicking on their row titles, then Select>Highlighted), then running
Analyse>Cluster>LINKTREE on the biotic Bray-Curtis similarity matrix with (Fitted data worksheet: Fal environment) and taking the other defaults, including (SIMPROF test). On the next
dialog screen again take all the defaults and, on the following screen supply another factor name (e.g.
Sprof linktree). The result is a slightly different form of tree diagram, a binary divisive cluster
analysis, again with statistically different groups shown by the black lines, and a text pane under the
plot in which each biotic division is explained by an inequality on the %silt/clay or Cu values, e.g.
the first split (A) is between the R1-R7 sites and the remaining samples with ‘explanation’ that Cu <
1350 to the left (the other creeks) and > 2000 to the right (Restronguet creek samples).

nMDS
ordination

The Basic MVA wizard next produces non-metric MDS (nMDS) plots in 2-d and 3-d. Ordination
plots of this type attempt to produce a ‘map’ of samples in which distances between pairs of points
reflect community (or environmental) resemblances between the respective pairs of samples – the
Bray-Curtis similarities here. Their associated Shepard diagrams are also plotted – these show how
well (or badly) the distances among samples in the low-d ordination approximate the similarities. If
the ‘stress’ is not too large (it is only 0.10 here), nMDS plots give a powerful representation of the
sample patterns. The Basic MVA wizard is here running (on the resemblance matrix) Analyse>
MDS>Non-metric MDS (nMDS) under default conditions. But running MDS directly there are
options to choose higher-d solutions and, more entertainingly, to watch MDS’s iterative process of
trying to obtain the lowest stress 2-d solution (say) from different restarts of sample points thrown
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randomly into 2-d, which you can activate, and even record as an *.mp4 file, by taking (Animate)
on the dialog. You will want to reduce the number of restarts (perhaps to 5), purely for the purposes
of watching the iteration in action (for a normal run of MDS, at least 50 restarts are recommended –
the default), and increase the accuracy with which stress is displayed by (Minimum stress: 0.001).
On the starting plot (and before setting the animation running with the right arrow video control),
take Graph>Special and the Overlays tab, with (Overlay trajectory)>(Trajectory numeric factor:
Position) and (Split trajectory: Creek). This will join the 5 (or 7) sample points on the plot in
sequence down the creeks, separately for each creek. It should help you not only to see the iteration
progress but also to note, in the final ordination, the gradient of community change along a creek, as
established for at least some of the creeks by the earlier ANOSIM tests. Note how some of the restarts
get trapped in a clearly sub-optimal solution – hence the need for many restarts. (There are other
recordable animations possible also, of spinning 3-d ordination plots and showing a dynamic
trajectory of, for example, an evolving time series of samples on an MDS or other ordination plot.)

PCA
ordination

Where the data matrix is environmental and (usually) the variables normalised, there is a choice of
ordination by PCA (Analyse>PCA run on the normalised data sheet) or nMDS on the Euclidean
distance resemblances. These are both offered by the Basic MVA wizard but can be run directly, of
course. Run PCA on the full set of (normalised) metal and silt-clay variables to get a synthesis of the
comparative environmental conditions over the 27 sites, taking all PCA defaults. The vector plot is
just a visual display of the eigenvectors in the results window – most of the heavy metal vectors lie
along the PC1 axis (left to right, below) showing their larger values in creek R compared with J and
E – they all have fairly large positive coefficients in the PC1 column but negligible PC2 values.
Creek M, high on the PC2 axis, has relatively higher values of Cr, Ni and %silt/clay.
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Note that by reversing both PC axes with Graph>Flip X and Flip Y and again adding a trajectory
as for the biotic ordination, the strong parallel between environmental and community structures of
these samples is apparent (and this idea is exploited further in the BEST routine).
An alternative to PCA here is Analyse>MDS>Metric MDS (mMDS), which fits a straight line to
the Shepard diagram of MDS (low-d) Euclidean distances vs original (high-d) Euclidean distances.
In one respect this improves on PCA, replacing PCA’s projection of points into low-d with more
careful placement of them, to optimise preservation of the high-d distances in the low-d structure.
Species
analyses

The final step in the Basic MVA wizard is to break down the dissimilarities (or distances) between
pairs of creeks into their contributions from each of the species (or abiotic variables), given in the
tables of SIMPER results. This is equivalent to running Analyse>SIMPER on the transformed data
matrix for biota (or normalised data matrix for abiotic variables). There are, however, several other
ways in which PRIMER examines variable relations to each other, or species relationships to the
sample patterns. We have already seen the strong potential shade plots have for interpretation, and
this is aided by the large number of options for grouping or ordering of their samples/species axes,
provided by Graph>Special>Reorder run on a Shade Plot.
Another possibility is Bubble plots of individual species values on the sample nMDS ordination: the
larger the bubble the greater the abundance of that species in that sample. For the Fal nMDS (on the
previous page), try this with Graph>Special>(Bubble plot) & (Worksheet: Fal nematode
abundance) & (Variables>Change), moving the currently displayed species (the first in the list,
Anoplostoma) to the Available box and Tripyloides gracilis to the Include box, and take the options
of (3D effect) and (Saturation: 75). It is neater to remove the site labels, since the trajectory lines
show the positions of the samples on the plot without distracting from the bubble display, so do this
by Graph>Sample labels & symbols, unchecking the box (Labels>Plot). Tripyloides gracilis is
clearly seen to be a species which is more abundant in the more impacted Restronguet creek.
Contrasting patterns can be seen for other species. When the active window is the nMDS bubble plot,
you might want to take Tools>Duplicate>(•On existing branch) to create an identical copy of the
first bubble plot. On this, Change the single species to Include, to Metachromadora vivipara, and
repeat for other species (e.g. Leptolaimus limicolus, Terschellingia sp.) Such species, helping to
discriminate the different creeks, can be identified from: a) the SIMPER routine; b) the earlier Shade
Plot; c) the wizard identifying sets of ‘coherent species curves’ (below). On another copy of the plot,
it is instructive to change to (Worksheet: Fal environment) and produce a bubble plot of Cu levels at
each site, on the nMDS of the communities, again making the biotic-abiotic link.
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Abundances for several species at once can be put onto a single segmented bubble plot, i.e. circle
sectors of different colours for the variables rather than for the Creek factor. Try moving the three
species Tripyloides gracilis, Metachromadora vivipara and Leptolaimus limicolus into the Include
box under the Change button, removing the trajectories and changing the (unfortunately!) clashing
colours used for each species by clicking on the bubble key and then the colour blocks.
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Coherent
variable sets

Calculating similarities (index of association) among species – not samples – or correlations among
environmental variables, in their pattern of response across the samples, opens up another field of
analyses, which we have already seen used to cluster species in the shade plot. Adapting SIMPROF
tests to operate on variable clusters (Type 3) rather than sample clusters (Type 1) permits definition
of coherent variable sets. Within each set, the variables (whether species or environment) are not
statistically distinguishable in their pattern of values over the samples, but across sets they show
significantly different responses. This is implemented in the third item on the Wizards menu.
You may find still find that only the two variables %silt/clay and Cu are selected in the sheet Fal
environment, from the earlier run of LINKTREE. If so, take Select>All to restore the full set of 12
heavy metal concentrations and sediment properties. (It is not necessary but you can clear the
highlighting either from Edit>Clear Highlight or by clicking in the blank top left box of the sheet).
Then run Wizards>Coherence plots on this Fal environment sheet. Take most of the defaults (e.g.
Pearson correlation is an appropriate measure of similarity of two abiotic response patterns and,
whilst this has an inbuilt normalisation, it is still necessary for the routine to normalise the supplied
matrix in order for the SIMPROF permutation procedure to work correctly). The changes it might be
advisable to make are to set (SIMPROF Sig.level(%): 0.5), since a number of tests are likely to be
carried out on the dendrogram, and (Number of permutations: 9999) – more stringent significance
levels need more permutations.
The dendrogram showing the cluster sets of variables is one output of this wizard, with red dashed
lines again indicating items that cannot be distinguished – technically, the variables have common
pairwise Pearson correlation among all pairs in the set. (The rotation of the plot can be convenient
for reading the variable labels and is achieved with Graph>Special). But the main output of the
wizard is a Multiplot of Line Plots of the 5 coherent variable sets: %site/clay, Pb, Ni as singleton
groups, Cr and % organic C in a doubleton and the remaining 7 heavy metals showing a striking
(and statistically indistinguishable) degree of uniformity over the sites. This is consistent with the
earlier PCA vector plots but is here able to demonstrate (as well as test) the nature of these patterns.
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Other
analyses

PRIMER 7 has many other analyses not mentioned above, e.g. RELATE tests for trends, seasonal
cyclicity or other model structures in community patterns; the BEST test for establishing whether
(observational) links to abiotic variables have overall statistical support; the 2STAGE routine which
– by defining similarity measures between entire multivariate patterns – can be used to assess the
relative importance of various decisions (choice of taxonomic level for identification, choice of transformation of the data matrix, choice of similarity coefficient etc) to the outcome of analyses, and also
facilitates a possible analysis of some repeated measures designs; and so on. There is also a range of
diagnostic displays aimed at determining whether low-d MDS or PCA ordinations give an adequate
representation of the original (dis)similarities, e.g. the Minimum Spanning Tree; a comparison of a
cluster analysis with an ordination by superimposing SIMPROF groups (e.g. given by the earlier
Sprof gp and Sprof linktree factors) as contours or symbols on the ordination plot (with
Graph>Special or Graph>Sample Labels & Symbols); combining a 2-d ordination with the whole
cluster analysis in a (3-d) ‘raised dendrogram’ plot etc.
PRIMER 7 also calculates a range of univariate (diversity-related) indices through the DIVERSE
menu, including those based on taxonomic or genetic/functional relatedness of the taxa (tested with
TAXDTEST), and also a range of diversity curves (e.g. dominance plots, species accumulation).
Other main menus (e.g. Select, Edit, Tools, Plots) offer a wide variety of data manipulations and
standard plotting functions (Means, Histogram, Box, Bar, Surface, Line and Scatter Plot).
One simple example of univariate index calculation and display for the Fal nematode data would be
to run Analyse>DIVERSE on the (untransformed) matrix Fal nematode abundance, selecting –from
the various tabs – indices such as S, Pielou, Shannon, Simpson, Hill’s N∞ and ESn rarefaction (if the
taxonomic distinctness indices in the final two tabs are required, you will need to File>Open the
taxonomy sheet Fal nematode taxonomy, detailing which species belong to which genera, families
etc). Taking (Results to worksheet), the resulting sheet can be entered into Plots>Means Plot,
specifying the Creek factor to give a set of standard univariate means plots.

Multivariate
means plots

A final example is of region estimates for means in multivariate data, e.g. average communities for
each of the Fal creeks, plotted on a 2- or 3-d MDS together with an approximate measure of the
uncertainty about these means, from bootstrapping. Run Analyse>Bootstrap Averages on the BrayCurtis resemblance matrix from the Fal biota, taking all the defaults, to get the multivariate means
plot. The regions’ nominal 95% value should not be taken too literally – potential sources of error
are unrepresented so these are not formal confidence regions – but they do reflect the earlier
ANOSIM pairwise test results here, with identifiably different average communities in all creeks.
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Finally, in the full package, you can save all plots in vector or various pixel formats to input to
graphics presentation software such as Powerpoint, with animations in .mp4 or animated .gif formats.
Any created Data sheets or Results windows, Notes etc can be separately saved (e.g. data to Excel
or to text files) but the primary saving and interchange format is the comprehensive PRIMER
workspace file (*.pwk), using File>Save Workspace As. This allows you to save the workspace and
re-open it later in exactly the same form, with File>Open. However, as with all saving, copying and
pasting, and printing operations, this is disabled in the trial version – see the detail given at the start
of these notes.
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